Probleas con Windows instalado en un pc Mac

Colapsar
X
  • Filtrar
  • Tiempo
  • Mostrar
Limpiar todos
nuevos mensajes

  • Probleas con Windows instalado en un pc Mac

    Hola a todos de nuevo.
    Bueno, bueno, no corráis que esta vez voy a ser breve.
    Tengo una aplicación TPV desarrollada hace ya unos años en VB6, que funciona perfectamente y que está instalada en un restaurante que tiene como PC un Mac e instalado en él una copia de Windows XP (que supongo estará adaptada para que funcione en ese entorno).
    Insisto en que el programa funciona sin problemas.
    Ahora (por enredar) me he puesto a trasladar la aplicación a Visual Studio Net 2012 y funciona perfectamente (en mi pc, claro).
    Al intentar instalar la aplicación en el Mac del que venimos hablando ni tan siquiera ejecuta el programa de instalación.
    He intentado cargar net Framenwork 4.5 y me dice que ese sistema operativo no lo admite.
    Y esta es mi pregunta:
    ¿Puede ser que el Windows XP que tiene instalado el Mac difiera del original de Microsoft y por eso no funcionan las .NET?
    El restaurante es propiedad de un amigo y me dice que si es preciso compraría Windows 7 o Windows 10, pero le he dicho que no se precipite porque yo creo que el probelma no es de XP.
    Y lo digo porque he instalado la aplicación en el PC de mi mujer que tiene Windos XP Professional y funciona sin problemas.
    De ahí que lo único que se me ocurre es que el S.O. tenga diferencias con el de Microsoft.
    No se si me habré explicado y podéis echarme una mano.
    Saludos a todos y gracias por vuestra paciencia.

  • #2
    Estimado amigo, tal como puedes verificar en la documentación Oficial de Microsoft sobre .NET Framework, notarás que Windows XP no soporta la versión 4.5, sino que sólo da soporte a la versión 4 como máximo:
    https://msdn.microsoft.com/es-cl/lib...or=-2147217396

    Saludos cordiales.
    Atentamente, Juan Ríos Pizarro...
    Saludos desde Chile...

    BLOG: http://www.metaltux.cl

    Comentario


    • #3
      Hola y gracias por contestar.
      La verdad es que no había visto ese condicionante NET Framework y probaré con la versión 3.5 o la 4,
      Saludos

      Comentario


      • #4
        Hola estimado, te ha resultado con el cambio realizado o no has tenido el tiempo de verificar eso?

        Saludos.
        Atentamente, Juan Ríos Pizarro...
        Saludos desde Chile...

        BLOG: http://www.metaltux.cl

        Comentario


        • #5
          Hola.
          He enviado a mi amigo del restaurante una copia del instalador con Framenwork 4 para que lo instale y espero que pronto me de noticias.
          En cuanto separ algo lo comunicaré por aquí.
          Saludos a todos

          Comentario

          Trabajando...
          X